Service interruption
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 15:40 UTC
Monitoring
We have resolved the issue that prevented users from logging in and will continue to monitor the situation.
Posted Dec 15, 2023 - 15:22 UTC
Investigating
Some users have reported not being able to login to Workboard. We are investigating and will keep you updated on our progress.
Posted Dec 15, 2023 - 14:44 UTC
This incident affected: Web App.