Service Interruption
Incident Report for WorkBoard
Resolved
This issue has been resolved. We will continue to monitor the situation.
Posted Jan 05, 2023 - 06:24 UTC
Update
We are continuing to actively investigate and resolve the service interruption as quickly as possible.
Posted Jan 05, 2023 - 05:56 UTC
Investigating
Some users may be experiencing difficulty accessing the WorkBoard EU system. We are actively investigating and all hands are on deck to resolve as quickly as possible.
Posted Jan 05, 2023 - 05:15 UTC
This incident affected: Web App.