Service interruption

Incident Report for WorkBoard

Resolved

We have been able to restore services to myworkboard.com. We will continue to monitor.
Posted May 05, 2025 - 02:03 UTC

Investigating

We are currently investigating an issue that may prevent some users from loading myworkboard.com. We apologize for the disruption.
Posted May 05, 2025 - 01:44 UTC
This incident affected: Web App.