Service interruption
Incident Report for WorkBoard
Resolved
We have resolved the intermittent latency issue and performance has returned to normal.
Posted Sep 08, 2023 - 08:05 UTC
Update
We continue investigating the intermittent latency issue with our upstream partners; some users may be experiencing slow load on certain pages. We will continue to keep you updated. We appreciate your patience.
Posted Sep 08, 2023 - 07:26 UTC
Update
We are continuing to work with our upstream partners to investigate the intermittent latency issue. We will share more as we make progress. Thank you for your patience.
Posted Sep 08, 2023 - 06:26 UTC
Update
We are still looking into the performance issue that may be affecting some customers using myworkboard.com. We remain all hands on deck.
Posted Sep 08, 2023 - 05:59 UTC
Investigating
We are currently investigating a performance issue that may affect some customers using myworkboard.com. We are all hands on deck to investigate and resolve this issue.
Posted Sep 08, 2023 - 05:11 UTC
This incident affected: Web App.