Service interruption
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Aug 30, 2022 - 00:35 UTC
Investigating
We are actively investigating an issue affecting the ability to save certain objects in WorkBoard. All hands are on deck to resolve as quickly as possible.
Posted Aug 30, 2022 - 00:31 UTC
This incident affected: Web App.