Service interruption

Incident Report for WorkBoard

Resolved

Access to our help center and support materials has been restored. This incident is resolved.
Posted Dec 17, 2025 - 17:57 UTC

Identified

We are aware of users' inability to access our help center and support materials. We are actively working with our vendor to restore access as quickly as possible.
Posted Dec 17, 2025 - 16:54 UTC
This incident affected: Web App.