Slow performance
Incident Report for WorkBoard
Resolved
We have identified and resolved the issue with the platform's performance.
Posted Sep 07, 2022 - 22:18 UTC
Identified
Performance has been stabilized and we are continuing to investigate the root cause.
Posted Sep 07, 2022 - 21:50 UTC
Update
We are continuing to investigate this issue.
Posted Sep 07, 2022 - 21:29 UTC
Investigating
Some users may be experiencing slow performance on the WorkBoard platform. We are actively investigating and all hands are on deck to resolve as quickly as possible.
Posted Sep 07, 2022 - 21:28 UTC
This incident affected: Web App.