Duplicate email notifications
Incident Report for WorkBoard
Resolved
We have stopped the duplicate email notifications and deployed a fix to the underlying issue.
Posted Oct 02, 2024 - 00:07 UTC
Investigating
We are investigating reports of duplicate KR Update email notifications for some users.
Posted Oct 01, 2024 - 23:30 UTC
This incident affected: Web App.