System Latency
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Dec 06, 2022 - 21:10 UTC
Monitoring
This issue has been resolved. Performance has been restored. We will continue to monitor the situation.
Posted Dec 06, 2022 - 19:37 UTC
Update
We are continuing to investigate this issue.
Posted Dec 06, 2022 - 18:31 UTC
Investigating
Some users may be intermittently experiencing slow performance on the WorkBoard platform. We are actively investigating, and all hands are on deck to resolve this as quickly as possible.
Posted Dec 06, 2022 - 18:31 UTC
This incident affected: Web App.