Some KRs missing updates
Incident Report for WorkBoard
Resolved
We have deployed a fix to restore all missing Key Result updates and data.
Posted Apr 03, 2023 - 13:32 UTC
Update
We have deployed a fix that will prevent further data loss. Our database team is continuing to work to restore any remaining missing updates and expects to have all missing data restored by end of day on Monday, April 3. Users can continue to create, set, and update Key Results and access them through the WorkBoard user interface. The data restoration process will not remove or overwrite any new or existing KR updates. Thank you for your patience.
Posted Mar 31, 2023 - 20:11 UTC
Identified
We will be working through the night to verify our fix in all scenarios. Our database team is pushing to get the data restored tonight and will provide an ETA as soon as available. We apologize for the inconvenience and we will continue to provide updates in the morning.
Posted Mar 31, 2023 - 03:11 UTC
Update
We have implemented a potential fix and are closely monitoring the situation. Our database team is working on restoring the missing updates. We apologize for the inconvenience and we will continue to provide updates.
Posted Mar 31, 2023 - 01:14 UTC
Update
We are continuing testing a fix for the missing KR Updates issue and are in parallel working on restoring the data. We apologize for the inconvenience and we will continue to provide you with updates.
Posted Mar 30, 2023 - 23:21 UTC
Update
We working on and testing a fix for the missing KR Updates issue and are in parallel working on restoring the data. We apologize for the inconvenience and we will continue to provide you with updates.
Posted Mar 30, 2023 - 21:39 UTC
Update
Another quick update! We are still actively investigating a fix, and all hands remain on deck. We apologize for the inconvenience and we will continue to provide you with updates.
Posted Mar 30, 2023 - 20:30 UTC
Update
Quick update! We are still actively investigating a fix, and all hands remain on deck. We apologize for the inconvenience and we will continue to provide you with updates.
Posted Mar 30, 2023 - 19:15 UTC
Update
We are continuing to work on the fix for missing update values on the some Key Results. We are all hands on deck.
Posted Mar 30, 2023 - 18:34 UTC
Update
We have identified candidate code changes that may be related to some Key Results showing as never being updated. We are qualifying rolling back these changes as we continue to test other potential root causes. We appreciate your patience.
Posted Mar 30, 2023 - 17:43 UTC
Update
We are still investigating unexpected behaviors with some Key Results. While this issue is not impacting all Key Results, we are pursuing this issue with maximum priority and we are exploring multiple approaches to resolve in parallel. We apologize for the disruption.
Posted Mar 30, 2023 - 17:04 UTC
Investigating
We are receiving reports that some Key Results are showing 0% progress or never having been updated. We are investigating this issue with critical priority and will share more information as we make progress.
Posted Mar 30, 2023 - 16:35 UTC
This incident affected: Web App.