Service Interruption
Incident Report for WorkBoard
Resolved
This service incident has been resolved.
Posted Mar 21, 2023 - 02:18 UTC
Monitoring
We have restored service for all affected users. We are continuing to monitor the situation and will continue to provide updates as needed
Posted Mar 21, 2023 - 02:02 UTC
Update
We are still all hands on deck and working to resolve the service incident preventing access to Workboard for some EU users.
Posted Mar 21, 2023 - 01:54 UTC
Investigating
We are aware of a service incident limiting access to Workboard for some of our EU customers. We are actively investigating and all hands are on deck to resolve as quickly as possible.
Posted Mar 21, 2023 - 01:22 UTC
This incident affected: Web App.