Service interruption
Incident Report for WorkBoard
Resolved
We have resolved this service incident. If you are still experiencing this issue please clear your browser cache and do a hard browser refresh.
Posted Mar 17, 2023 - 06:09 UTC
Update
We are still experiencing a service incident that is limiting access to Workboard for some users. We are continuing to engage with our upstream providers to expedite service restoration.
Posted Mar 17, 2023 - 05:32 UTC
Update
We are continuing to engage with our upstream providers to resolve the ongoing service incident for all affected users.
Posted Mar 17, 2023 - 04:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2023 - 04:23 UTC
Investigating
We are aware of a service incident limiting access to WorkBoard for some users. We have raised a ticket with our upstream providers with Critical priority to expedite service being restored.
Posted Mar 17, 2023 - 04:18 UTC
This incident affected: Web App.