Slow Performance
Incident Report for WorkBoard
Resolved
We have resolved the issue with the platform's performance.
Posted Nov 10, 2022 - 18:22 UTC
Update
We have identified a fix and plan to release it within the hour. We will provide updates on our progress here.
Posted Nov 10, 2022 - 17:52 UTC
Identified
The issue has been identified and a fix is being tested for release as soon as possible.
Posted Nov 10, 2022 - 17:15 UTC
Investigating
Some users may be experiencing slow performance on the WorkBoard platform. We are actively investigating and all hands are on deck to resolve this as quickly as possible..
Posted Nov 10, 2022 - 16:23 UTC
This incident affected: Web App.