Service Interruption
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Sep 22, 2024 - 15:09 UTC
Monitoring
We have identified the issue causing some pages not to load and preventing some users from logging in. We are monitoring the issue now.
Posted Sep 20, 2024 - 09:13 UTC
Investigating
We are aware of an issue that is preventing users from accessing Workboard. Our engineering team is actively investigating the issue. We will keep you updated as we find out more.
Posted Sep 20, 2024 - 09:01 UTC
This incident affected: Web App.