Intermittent system slowdown
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 06:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Performance has been back to normal.
Posted Sep 16, 2021 - 02:04 UTC
Update
We are continuing to investigate this issue.
Posted Sep 15, 2021 - 23:27 UTC
Investigating
Some customers are experiencing sporadic issues and delays when accessing WorkBoard. All hands are on deck working to resolve the issue!
Posted Sep 15, 2021 - 23:18 UTC
This incident affected: Web App.