Search delays
Incident Report for WorkBoard
Resolved
This incident has been resolved.
Posted Dec 02, 2023 - 02:07 UTC
Investigating
We're currently addressing an issue where our platform's search functionality may not return expected results. Our team is diligently working to resolve this and restore consistent and reliable search performance as soon as possible.
Posted Dec 01, 2023 - 23:29 UTC
This incident affected: Web App.