Service interruption

Incident Report for WorkBoard

Resolved

The issue was identified and resolved. We will continue to monitor.
Posted Jun 25, 2025 - 13:48 UTC

Investigating

We are aware of an issue preventing some users of myworkboard.eu from updating OKRs. We are investigating and will keep you updated as we make progress.
Posted Jun 25, 2025 - 12:54 UTC
This incident affected: Web App.