Workboard Learn Service Interruption

Incident Report for WorkBoard

Resolved

The Skilljar incident has been resolved and learn.workboard.com is operational again.
Posted Aug 06, 2025 - 17:35 UTC

Identified

Workboard Learn is experiencing a service interruption because of an ongoing incident with our vendor, Skilljar. You can stay up to date on the incident here: https://status.skilljar.com/
Posted Aug 06, 2025 - 14:50 UTC
This incident affected: Web App.